Páginas

lunes, 29 de marzo de 2021

Configurar y permitir el enrutamiento inter-VLAN Cisco EVE-NG

En computación, un Router on A Stick (ROAS), es un router que tiene una sola conexión física o lógica a una red. Es un método de ruteo inter-VLAN (redes de área local virtual) donde un router está conectado a un Switch vía un solo cable. El router tiene conexiones físicas a los dominios de broadcast donde uno o más VLAN requieren de enrutamiento entre ellos.



Configurar Sw1 y Sw2 como switches VTP transparentes:

Sw1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Sw1(config)#vtp mode Transparent
Setting device to VTP TRANSPARENT mode.
Sw1(config)#vtp domain CISCO
Changing VTP domain name from NULL to CISCO
Sw1(config)#vtp password cisco-vtp
Setting device VLAN database password to cisco-vtp
Sw1(config)#do sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 36
Number of existing VLANs        : 5
VTP Operating Mode              : Transparent
VTP Domain Name                 : CISCO
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0xD3 0x78 0x64 0x81 0xE5 0xE4 0x17
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Sw1(config)#

Sw2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Sw2(config)#vtp mode Transparent
Setting device to VTP TRANSPARENT mode.
Sw2(config)#vtp domain CISCO
Changing VTP domain name from NULL to CISCO
Sw2(config)#vtp password cisco-vtp
Setting device VLAN database password to cisco-vtp
Sw2(config)#do sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 36
Number of existing VLANs        : 5
VTP Operating Mode              : Transparent
VTP Domain Name                 : CISCO
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0xD3 0x78 0x64 0x81 0xE5 0xE4 0x17
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Sw2(config)#

Vlans 10,20,30,40 y su nombre correspondiente. Interface e0/0 y e0/1 modo trunk, permitir vlan 1,10,20,30,40. Interface e0/2 access vlan 20.

Sw1#config t
Enter configuration commands, one per line. End with CNTL/Z. 
Sw1(config)#interface e0/0
Sw1(config-if)#switchport mode trunk
Sw1(config-if)#exit
Sw1(config)#vlan 10
Sw1(config-vlan)#name SALES
Sw1(config-vlan)#exit
Sw1(config)#vlan 20
Sw1(config-vlan)#name STATIC
Sw1(config-vlan)#exit
Sw1(config)#vlan 30
Sw1(config-vlan)#name ADMIN
Sw1(config-vlan)#exit
Sw1(config)#interface e0/0
Sw1(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Sw1(config)#vlan 40
Sw1(config-vlan)#name VoIP 
Sw1(config-vlan)#exit
Sw1(config)#interface e0/1 
Sw1(config-if)#switchport mode trunk 
Sw1(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Sw1(config-if)#exit
Sw1(config)#interface e0/2 
Sw1(config-if)#switchport mode access 
Sw1(config-if)#switchport access vlan 20 
Sw1(config-if)#end
Sw1#

Verificar interfaces trunk en sw1:

Sw1#sh interfaces trunk

Port        Mode          Encapsulation  Status      Native vlan
Et0/0       on               802.1q         trunking      1
Et0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/0       1,10,20,30,40
Et0/1       1,10,20,30,40

Port        Vlans allowed and active in management domain
Et0/0       1,10,20,30,40
Et0/1       1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20,30,40
Et0/1       1,10,20,30,40
Sw1#

Vlans Switch 1:

Sw1#sh vlan b

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                         active    Et0/3
10   SALES                       active
20   STATIC                      active    Et0/2
30   ADMIN                      active
40   VoIP                            active
1002 fddi-default               act/unsup
1003 token-ring-default     act/unsup
1004 fddinet-default          act/unsup
1005 trnet-default              act/unsup
Sw1#

Vlans 10,20,30,40 y su nombre correspondiente. Interface e0/0 modo trunk, permitir vlan 1,10,20,30,40. Interface e0/1 access vlan 30, interface e0/2 access vlan 40.

Sw2#config t
Enter configuration commands, one per line. End with CNTL/Z.
Sw2(config)#interface e0/0 
Sw2(config-if)#switchport mode trunk 
Sw2(config-if)#exit
Sw2(config)#vlan 10 
Sw2(config-vlan)#name SALES 
Sw2(config-vlan)#exit
Sw2(config)#vlan 20 
Sw2(config-vlan)#name STATIC 
Sw2(config-vlan)#exit
Sw2(config)#vlan 30 
Sw2(config-vlan)#name ADMIN 
Sw2(config-vlan)#exit
Sw2(config)#vlan 40 
Sw2(config-vlan)#name VoIP 
Sw2(config-vlan)#exit 
Sw2(config)#interface e0/0 
Sw1(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Sw2(config)#interface e0/1 
Sw2(config-if)#switchport mode access 
Sw2(config-if)#switchport access vlan 30 
Sw2(config-if)#exit
Sw2(config)#interface e0/2
Sw2(config-if)#switchport mode access 
Sw2(config-if)#switchport access vlan 40 
Sw2(config-if)#^Z
Sw2#

Verificar interfaces trunk en sw2:

Sw2#show interfaces trunk
Port        Mode          Encapsulation  Status     Native vlan
Et0/0       on              802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/0       1,10,20,30,40

Port        Vlans allowed and active in management domain
Et0/0       1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20,30,40
Sw2#

Vlans en switch2:

Sw2#sh vlan b

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/3
10   SALES                        active
20   STATIC                       active
30   ADMIN                       active    Et0/1
40   VoIP                            active    Et0/2
1002 fddi-default               act/unsup
1003 token-ring-default     act/unsup
1004 fddinet-default          act/unsup
1005 trnet-default              act/unsup
Sw2#

Router On A Stick (ROAS) en R1:

R1#config t
Enter configuration commands, one per line. End with CNTL/Z. 
R1(config)#interface e0/0
R1(config-if)#description "Connected a Sw1 Trunk e0/1" 
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface e0/0.10 
R1(config-subif)#description Subinterface Para VLAN 10 
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 10.0.10.1 255.255.255.240 R1(config-subif)#exit
R1(config)#interface e0/0.20 
R1(config-subif)#description Subinterface Para VLAN 20 
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 10.0.20.1 255.255.255.128 
R1(config-subif)#exit
R1(config)#interface e0/0.30
R1(config-subif)#description Subinterface Para VLAN 30 
R1(config-subif)#ip address 10.0.30.1 255.255.255.248 
R1(config-subif)#exit
R1(config)#interface e0/0.40 
R1(config-subif)#description Subinterface Para VLAN 40 
R1(config-subif)#encapsulation dot1Q 40 
R1(config-subif)#ip address 10.0.40.1 255.255.255.224 
R1(config-subif)#end
R1#

Verificar configuración:

R1#show ip interface brief
R1#sh ip interface b
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  up                    up
Ethernet0/0.10             10.0.10.1       YES NVRAM  up                    up
Ethernet0/0.20             10.0.20.1       YES NVRAM  up                    up
Ethernet0/0.30             10.0.30.1       YES NVRAM  up                    up
Ethernet0/0.40             10.0.40.1       YES NVRAM  up                    up
Ethernet0/1                unassigned      YES NVRAM  administratively down down
Ethernet0/2                unassigned      YES NVRAM  administratively down down
Ethernet0/3                unassigned      YES NVRAM  administratively down down
R1#

Dirección IP 10.0.10.2/28 (Vlan 10):

Sw2#conf t
Sw2(config)#interface vlan10
Sw2(config-if)#ip address 10.0.10.2 255.255.255.240 
Sw2(config-if)#no shutdown
Sw2(config)#^Z
Sw2#

Comprobar:

Sw2#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES unset  up                    up
Ethernet0/1            unassigned      YES unset  up                    up
Ethernet0/2            unassigned      YES unset  up                    up
Ethernet0/3            unassigned      YES unset  administratively down down
Vlan1                  unassigned      YES unset  administratively down down
Vlan10                 10.0.10.2       YES manual up                    up
Vlan20                 unassigned      YES unset  administratively down down
Vlan30                 unassigned      YES unset  administratively down down
Vlan40                 unassigned      YES unset  administratively down down
Sw2#

Ping, comprobar conectividad:

R1#ping 10.0.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.10.2, timeout is 2 seconds: .!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms 

R1#ping 10.0.20.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.20.2, timeout is 2 seconds: .!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms 

R1#ping 10.0.30.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.30.3, timeout is 2 seconds: .!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms 

R1#ping 10.0.40.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.40.4, timeout is 2 seconds: .!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms

Archivos de configuración de todos los dispositivos:

Sw1#sh run
Building configuration...

Current configuration : 1150 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Sw1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
no ipv6 cef
ipv6 multicast rpf use-bgp
!
no ip domain-lookup
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,10,20,30,40
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,10,20,30,40
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Vlan10
 no ip address
 shutdown
!
interface Vlan20
 no ip address
 shutdown
!
interface Vlan30
 no ip address
 shutdown
!
interface Vlan40
 no ip address
 shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end


Sw2#sh run
Building configuration...

Current configuration : 1278 bytes
!
! Last configuration change at 20:05:49 CET Mon Mar 29 2021
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Sw2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
no ipv6 cef
ipv6 multicast rpf use-bgp
!
no ip domain-lookup
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,10,20,30,40
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport access vlan 30
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 40
 switchport mode access
 duplex auto
!
interface Ethernet0/3
 switchport mode access
 shutdown
 duplex auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 10.0.10.2 255.255.255.240
!
interface Vlan20
 no ip address
 shutdown
!
interface Vlan30
 no ip address
 shutdown
!
interface Vlan40
 no ip address
 shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Sw2#

R1#sh run
Building configuration...

Current configuration : 1561 bytes
!
! Last configuration change at 20:13:31 CET Mon Mar 29 2021
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 description "Connected a Sw1 Trunk e0/1"
 no ip address
 duplex auto
!
interface Ethernet0/0.10
 description -Subinterface For VLAN 10"
 encapsulation dot1Q 10
 ip address 10.0.10.1 255.255.255.240
!
interface Ethernet0/0.20
 description -Subinterface For VLAN 20"
 encapsulation dot1Q 20
 ip address 10.0.20.1 255.255.255.128
!
interface Ethernet0/0.30
 description -Subinterface For VLAN 30"
 encapsulation dot1Q 30
 ip address 10.0.30.1 255.255.255.248
!
interface Ethernet0/0.40
 description -Subinterface For VLAN 40"
 encapsulation dot1Q 40
 ip address 10.0.40.1 255.255.255.224
!
interface Ethernet0/1
 no ip address
 shutdown
 duplex auto
!
interface Ethernet0/2
 no ip address
 shutdown
 duplex auto
!
interface Ethernet0/3
 no ip address
 shutdown
 duplex auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

R1#


R2#sh run
Building configuration...

Current configuration : 1006 bytes
!
! Last configuration change at 15:16:01 CET Mon Mar 29 2021
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.0.20.2 255.255.255.128
 duplex auto
!
interface Ethernet0/1
 no ip address
 shutdown
 duplex auto
!
interface Ethernet0/2
 no ip address
 shutdown
 duplex auto
!
interface Ethernet0/3
 no ip address
 shutdown
 duplex auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

R2#


R3#sh run
Building configuration...

Current configuration : 1013 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone CET 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!
!
ip cef
multilink bundle-name authenticated
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.0.30.3 255.255.255.224
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
no ip http server
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

R3#



R4#sh run
Building configuration...

Current configuration : 1013 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone CET 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!
!
ip cef
multilink bundle-name authenticated
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.0.40.4 255.255.255.224
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
no ip http server
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

R4#






Cisco es genial!.

sábado, 20 de marzo de 2021

OSPF Vlan 30 Cisco


Implementar VLAN 30 y comprobar conectividad. El proceso es el mismo para VLAN 40, excepto las interfaces Trunk que ya permiten el paso de VLAN 40:

1.- Switch Access interfaces Fa0/1 y Fa0/2 Allowed vlans 1,10,20,30,40.
2.- Core1 interfaces Trunk - Gig1/0/1, Gig1/0/2, Gig1/0/14, Gig1/0/15 - Permitir vlans 1,10,20,30,40
3.- Core2 interfaces Gig1/0/2, Gig1/0/14 , Gig1/0/15 Permitir vlans 1,10,20,30,40
4.- Router 2 crear vlan 30 (ROAS) - interface gigabitEthernet 0/1.30 y asignar direccionamiento IP.
5.- Switch SW-VA interface Fa0/1 Allowed vlans 1,10,20,30,40 y  
switchport access vlan 30 interface fastEthernet 0/3
6.- Router 1 R1-NV crear vlan 30 - interface gigabitEthernet 0/0.30 y asignar direccionameinteo IP.
7.- Comprobar conectividad.


Access#sh inter
Access#sh interfaces tr
Access#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1,10,20
Fa0/2       1,10,20

Port        Vlans allowed and active in management domain
Fa0/1       1,10,20
Fa0/2       1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20
Fa0/2       none

Access#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Access(config)#inter
Access(config)#interface range fa
Access(config)#interface range fastEthernet 0/1-2
Access(config-if-range)#sw
Access(config-if-range)#switchport trunk allo
Access(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
Access(config-if-range)#^Z
Access#
%SYS-5-CONFIG_I: Configured from console by console

Access#wri
Building configuration...
[OK]

Access#sh inter
Access#sh interfaces tr
Access#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1,10,20,30,40
Fa0/2       1,10,20,30,40

Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,30,40
Fa0/2       1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       none
Fa0/2       none

Access#wri
Building configuration...
[OK]
Access#


Core1#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/1    on           802.1q         trunking      1
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/1    1,10,20
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   1,10,20

Port        Vlans allowed and active in management domain
Gig1/0/1    1,10,20
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/1    1,10,20
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   1,10,20

Core1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core1(config)#interfaces range gi
Core1(config)#inter
Core1(config)#interface range
Core1(config)#interface range g
Core1(config)#interface range gigabitEthernet 1/0/1-2
Core1(config-if-range)#sw
Core1(config-if-range)#switchport tr
Core1(config-if-range)#switchport trunk all
Core1(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
Core1(config-if-range)#exit
Core1(config)#interface range gigabitEthernet 1/0/14-15
Core1(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
Core1(config-if-range)#^Z
Core1#
%SYS-5-CONFIG_I: Configured from console by console

Core1#wri
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Core1#sh inter
Core1#sh interfaces tr
Core1#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/1    on           802.1q         trunking      1
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/1    1,10,20,30,40
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans allowed and active in management domain
Gig1/0/1    1,10,20,30,40
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/1    none
Gig1/0/2    none
Gig1/0/14   none
Gig1/0/15   none

Core1#



Core2#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   1,10,20

Port        Vlans allowed and active in management domain
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/2    1,10,20
Gig1/0/14   1,10,20
Gig1/0/15   none

Core2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core2(config)#inter
Core2(config)#interface g
Core2(config)#interface gigabitEthernet 1/0/2
Core2(config-if)#sw
Core2(config-if)#switchport tr
Core2(config-if)#switchport trunk all
Core2(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core2(config-if)#^Z
Core2#
%SYS-5-CONFIG_I: Configured from console by console

Core2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core2(config)#inter
Core2(config)#interface g
Core2(config)#interface range gigabitEthernet 1/0/14-15
Core2(config-if-range)#sw
Core2(config-if-range)#switchport tr
Core2(config-if-range)#switchport trunk all
Core2(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
Core2(config-if-range)#^Z
Core2#
%SYS-5-CONFIG_I: Configured from console by console

Core2#wri
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Core2#sh inter
Core2#sh interfaces tr
Core2#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans allowed and active in management domain
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/2    1,10,20,30,40
Gig1/0/14   none
Gig1/0/15   none

Core2#



R2-VA#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     10.16.7.6       YES manual up                    up 
GigabitEthernet0/1     unassigned      YES unset  up                    up 
GigabitEthernet0/1.10  10.16.8.1       YES manual up                    up 
GigabitEthernet0/1.20  10.16.10.1      YES manual up                    up 
GigabitEthernet0/2     unassigned      YES unset  administratively down down 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Loopback0              2.2.2.2         YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R2-VA#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2-VA(config)#inter
R2-VA(config)#interface g
R2-VA(config)#interface gigabitEthernet 0/1.30
R2-VA(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1.30, changed state to up

R2-VA(config-subif)#ip add
R2-VA(config-subif)#ip address 10.16.12.1 255.255.254.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

R2-VA(config-subif)#encapsulation dot1Q 
% Incomplete command.
R2-VA(config-subif)#encapsulation dot1Q 30
R2-VA(config-subif)#ip address 10.16.12.1 255.255.254.0
R2-VA(config-subif)#exit
R2-VA(config)#

R2-VA#wri
Building configuration...
[OK]

R2-VA#sh ip inter
R2-VA#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     10.16.7.6       YES manual up                    up 
GigabitEthernet0/1     unassigned      YES unset  up                    up 
GigabitEthernet0/1.10  10.16.8.1       YES manual up                    up 
GigabitEthernet0/1.20  10.16.10.1      YES manual up                    up 
GigabitEthernet0/1.30  10.16.12.1      YES manual up                    up 
GigabitEthernet0/2     unassigned      YES unset  administratively down down 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Loopback0              2.2.2.2         YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R2-VA#


SW-VA#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1,10,20,30,40

Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,30,40

SW-VA#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW-VA(config)#inter
SW-VA(config)#interface fa
SW-VA(config)#interface fastEthernet 0/3
SW-VA(config-if)#sw
SW-VA(config-if)#switchport mode
SW-VA(config-if)#switchport mode acc
SW-VA(config-if)#switchport mode access 
SW-VA(config-if)#sw
SW-VA(config-if)#switchport ac
SW-VA(config-if)#switchport access vlan 30
SW-VA(config-if)#^Z
SW-VA#
%SYS-5-CONFIG_I: Configured from console by console

SW-VA#wri
Building configuration...
[OK]
SW-VA#


R1-NV#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES unset  up                    up 
GigabitEthernet0/0.10  10.16.0.1       YES manual up                    up 
GigabitEthernet0/0.20  10.16.2.1       YES manual up                    up 
GigabitEthernet0/1     10.16.7.5       YES manual up                    up 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES unset  down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Loopback0              1.1.1.1         YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R1-NV#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1-NV(config)#inter
R1-NV(config)#interface g
R1-NV(config)#interface gigabitEthernet 0/0.30
R1-NV(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up

R1-NV(config-subif)#ip add
R1-NV(config-subif)#ip address 10.16.4.1 255.255.254.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

R1-NV(config-subif)#encap
R1-NV(config-subif)#encapsulation do
R1-NV(config-subif)#encapsulation dot1Q 30
R1-NV(config-subif)#ip address 10.16.4.1 255.255.254.0
R1-NV(config-subif)#^Z
R1-NV#
%SYS-5-CONFIG_I: Configured from console by console

R1-NV#wri
Building configuration...
[OK]
R1-NV#

R1-NV#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES unset  up                    up 
GigabitEthernet0/0.10  10.16.0.1       YES manual up                    up 
GigabitEthernet0/0.20  10.16.2.1       YES manual up                    up 
GigabitEthernet0/0.30  10.16.4.1       YES manual up                    up 
GigabitEthernet0/1     10.16.7.5       YES manual up                    up 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES unset  down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Loopback0              1.1.1.1         YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R1-NV#



Cisco es genial!.

jueves, 18 de marzo de 2021

VLANs Trunk Routing ROAS Cisco


1.- Permitir solo las vlan 1,10,20 en las interfaces Trunk
2.- Interfaz que conecta a Core 1 cambiar a GigabitEthernet 
2.- Eliminar las Vlans y direcciones IPs.
3.- Gig0/0 no shut
3.- En el router R1-NV implementar Router On A Stick (ROAS), trunking encapsulation dot1Q
4.- Comprobar conectividad

Escenario actual:


R1-NV#sh interfaces tr
R1-NV#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/0/0     on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/0/0     1

Port        Vlans allowed and active in management domain
Fa0/0/0     1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/0/0     1

R1-NV#sh ip inter
R1-NV#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual administratively down down 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    up 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES manual down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down 
Vlan10                 10.16.0.1       YES manual up                    up 
Vlan20                 10.16.2.1       YES manual up                    up 
Vlan30                 10.16.4.1       YES manual up                    up 
Vlan40                 10.16.6.1       YES manual up                    up
R1-NV#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1-NV(config)#inter
R1-NV(config)#no interface vlan 10
R1-NV(config)#
%LINK-5-CHANGED: Interface Vlan10, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down

R1-NV(config)#no interface vlan 20
R1-NV(config)#
%LINK-5-CHANGED: Interface Vlan20, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to down

R1-NV(config)#no interface vlan 30
R1-NV(config)#
%LINK-5-CHANGED: Interface Vlan30, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to down

R1-NV(config)#no interface vlan 40
R1-NV(config)#
%LINK-5-CHANGED: Interface Vlan40, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to down

R1-NV(config)#do wri
Building configuration...
[OK]
R1-NV(config)#^Z
R1-NV#
%SYS-5-CONFIG_I: Configured from console by console

R1-NV#sh ip inter
R1-NV#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual administratively down down 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    up 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES manual down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down
R1-NV#

R1-NV#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1-NV(config)#inter
R1-NV(config)#interface g
R1-NV(config)#interface gigabitEthernet 0/0
R1-NV(config-if)#no shut

R1-NV(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R1-NV(config-if)#exit
R1-NV(config)#inter
R1-NV(config)#interface g
R1-NV(config)#interface gigabitEthernet 0/0.10
R1-NV(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed state to up

R1-NV(config-subif)#enca
R1-NV(config-subif)#encapsulation do
R1-NV(config-subif)#encapsulation dot1Q 10
R1-NV(config-subif)#ip add
R1-NV(config-subif)#ip address 10.16.0.1 255.255.255.0
R1-NV(config-subif)#exit
R1-NV(config)#interface gigabitEthernet 0/0.20
R1-NV(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up

R1-NV(config-subif)#encapsulation dot1Q 20
R1-NV(config-subif)#ip address 10.16.2.1 255.255.255.0
R1-NV(config-subif)#exit
R1-NV(config)#do sh ip inter
R1-NV(config)#do sh ip inter b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual up                    up 
GigabitEthernet0/0.10  10.16.0.1       YES manual up                    up 
GigabitEthernet0/0.20  10.16.2.1       YES manual up                    up 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES manual down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down

R1-NV(config-if)#exit
R1-NV(config)#interface gigabitEthernet 0/0.10
R1-NV(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed state to up

R1-NV(config-subif)#encapsulation do
R1-NV(config-subif)#encapsulation dot1Q 10
R1-NV(config-subif)#ip add
R1-NV(config-subif)#ip address 10.16.0.1 255.255.255.0
R1-NV(config-subif)#exit
R1-NV(config)#interface gigabitEthernet 0/0.20
R1-NV(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up

R1-NV(config-subif)#encapsulation dot1Q 20
R1-NV(config-subif)#ip address 10.16.2.1 255.255.255.0
R1-NV(config-subif)#exit
R1-NV(config)#do sh ip inter
R1-NV(config)#do sh ip inter b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual up                    up 
GigabitEthernet0/0.10  10.16.0.1       YES manual up                    up 
GigabitEthernet0/0.20  10.16.2.1       YES manual up                    up 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    down 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES manual down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down

Ping desde el router R1 hacia PC10

R1-NV#ping 10.16.0.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.16.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

R1-NV#ping 10.16.2.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.16.2.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Comprobando conectividad:

R1-NV#

R1-NV#ping 10.16.0.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.16.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

R1-NV#ping 10.16.2.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.16.2.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

R1-NV#

Ping desde PC20 VLAN 20

C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::201:63FF:FE51:CDBB
   IP Address......................: 10.16.2.10
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 10.16.2.1

C:\>ping 10.16.2.1

Pinging 10.16.2.1 with 32 bytes of data:

Reply from 10.16.2.1: bytes=32 time<1ms TTL=255
Reply from 10.16.2.1: bytes=32 time<1ms TTL=255
Reply from 10.16.2.1: bytes=32 time=3ms TTL=255
Reply from 10.16.2.1: bytes=32 time<1ms TTL=255

Ping statistics for 10.16.2.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 3ms, Average = 0ms

C:\>ping 10.16.0.10

Pinging 10.16.0.10 with 32 bytes of data:

Reply from 10.16.0.10: bytes=32 time<1ms TTL=127
Reply from 10.16.0.10: bytes=32 time=1ms TTL=127
Reply from 10.16.0.10: bytes=32 time<1ms TTL=127
Reply from 10.16.0.10: bytes=32 time<1ms TTL=127

Ping statistics for 10.16.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\>tracert 10.16.0.10

Tracing route to 10.16.0.10 over a maximum of 30 hops: 

  1   0 ms      0 ms      0 ms      10.16.2.1
  2   0 ms      0 ms      0 ms      10.16.0.10

Trace complete.

C:\>

Ping desde PC10 VLAN 10



Cisco es genial!.

miércoles, 17 de marzo de 2021

Implementar VLSM en una Red VLAN Cisco


Implementar conectividad en Sitio Principal (Navarra) utilizando VLANs. 


Aplicar una configuración de switch multicapa a un módulo  del router para proporcionar enrutamiento al sitio principal - Navarra.

1.- Crear las Vlans en R1-NV.
Crear las VLANs - SVI (Switch Virtual Interface) y las Layer 3 Switch Virtual Interfaces.
2.- Asignar direcciones IP del segmento correspondiente a cada Vlan. Estas IPs serán las puertas de enlace predeterminadas, (default gateway).
3.- Modo Trunk en la interfaz Fa0/0/0
4.- Modo Trunk en el otro extremo Gig1/0/1 Core1.
5.- Configurar las Vlans en todos los switches.
6.- Modo Trunk entre las interfaces que conectan los switches, nonegotiate, allowed vlan 1,10,20,30,40.
7.- Modo Access en los clientes finales, Vlan 10, Vlan 20, Vlan 30, Vlan 40.
8.- Comprobar conectividad.

R1 NAVARRA

R1-NV#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1-NV(config)#interface vlan 10
R1-NV(config-if)#exit
R1-NV(config)#inter
R1-NV(config)#interface vlan 10
R1-NV(config-if)#ip address 10.16.0.1 255.255.255.0
R1-NV(config-if)#exit
R1-NV(config)#interface vlan 20
R1-NV(config-if)#ip address 10.16.2.1 255.255.255.0
R1-NV(config-if)#exit
R1-NV(config)#inter vlan 30
R1-NV(config-if)#ip address 10.16.4.1 255.255.254.0
R1-NV(config-if)#exit
R1-NV(config)#interface vlan 40
R1-NV(config-if)#ip address 10.16.6.1 255.255.254.0
R1-NV(config-if)#

10.16.0.1 es el GW por defecto de la VLAN 10 SVI

La interfaz que conecta con el Switch (Core1) fastEthernet 0/0/0 en modo Trunk. Todas las Vlans quedan activas (up).

R1-NV#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1-NV(config)#inter
R1-NV(config)#interface fa
R1-NV(config)#interface fastEthernet 0/0/0
R1-NV(config-if)#switchport mode
R1-NV(config-if)#switchport mode tr
R1-NV(config-if)#switchport mode trunk 
R1-NV(config-if)#switchport nonegotiate 

R1-NV(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0/0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up

R1-NV(config-if)#do sh ip inter b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual administratively down down 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     unassigned      YES unset  up                    down 
FastEthernet0/0/0      unassigned      YES unset  up                    up 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES unset  down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down 
Vlan10                 10.16.0.1       YES manual up                    up 
Vlan20                 10.16.2.1       YES manual up                    up 
Vlan30                 10.16.4.1       YES manual up                    up 
Vlan40                 10.16.6.1       YES manual up                    up
R1-NV(config-if)#
R1-NV#

Core1#sh cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Core2        Gig 1/0/14       177                    3650        Gig 1/0/14
Core2        Gig 1/0/15       177                    3650        Gig 1/0/15
Access       Gig 1/0/2        177            S       2960        Fas 0/1
R1-NV        Gig 1/0/1        155            R       C2900       Fas 0/0/0
Core1#

Core1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core1(config)#int
Core1(config)#interface g
Core1(config)#interface gigabitEthernet 1/0/1
Core1(config-if)#switchport trunk enca
Core1(config-if)#switchport trunk encapsulation do
Core1(config-if)#switchport trunk encapsulation dot1q 
Core1(config-if)#switchport mode tr
Core1(config-if)#switchport mode trunk 
Core1(config-if)#switchport nonegotiate 

Core1(config-if)#switchport trunk all

Core1(config-if)#switchport trunk allowed vlan 1,10,20,30,40

Core1(config-if)#


Core1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up

Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Core1#

Core1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core1(config)#interface gigabitEthernet 1/0/2
Core1(config-if)#switchport trunk enc
Core1(config-if)#switchport trunk encapsulation do
Core1(config-if)#switchport trunk encapsulation dot1q 
Core1(config-if)#switchport mode trunk 
Core1(config-if)#switchport nonegotiate
Core1(config-if)#switchport trunk allowed vlan 1,10,20,30,40

Core1#

Core1(config)#interface gigabitEthernet 1/0/14
Core1(config-if)#switchport trunk all
Core1(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core1(config-if)#switchport nonegotiate

Core1(config-if)#exit
Core1(config)#interface gigabitEthernet 1/0/15
Core1(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core1(config-if)#switchport nonegotiate

Core1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core1(config)#vlan 10
Core1(config-vlan)#name VLAN10
Core1(config-vlan)#exit
Core1(config)#inter
Core1(config)#interface vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Core1(config-if)#exit
Core1(config)#vlan 20
Core1(config-vlan)#name VLAN20
Core1(config-vlan)#exit
Core1(config)#interface vlan 20
Core1(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Core1(config-if)#exit
Core1(config)#vlan 30
Core1(config-vlan)#name VLAN30
Core1(config-vlan)#exit
Core1(config)#interface vlan 30
Core1(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

Core1(config-if)#exit
Core1(config)#vlan 40
Core1(config-vlan)#name VLAN40
Core1(config-vlan)#exit
Core1(config)#interface vlan 40
Core1(config-if)#
%LINK-5-CHANGED: Interface Vlan40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up

Core1(config-if)#exit
Core1(config)#^Z
Core1#
%SYS-5-CONFIG_I: Configured from console by console

Core1#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gig1/0/3, Gig1/0/4, Gig1/0/5, Gig1/0/6
                                                Gig1/0/7, Gig1/0/8, Gig1/0/9, Gig1/0/10
                                                Gig1/0/11, Gig1/0/12, Gig1/0/13, Gig1/0/16
                                                Gig1/0/17, Gig1/0/18, Gig1/0/19, Gig1/0/20
                                                Gig1/0/21, Gig1/0/22, Gig1/0/23, Gig1/0/24
                                                Gig1/1/1, Gig1/1/2, Gig1/1/3, Gig1/1/4
10   VLAN10                         active    
20   VLAN20                         active    
30   VLAN30                         active    
40   VLAN40                         active    
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0

Core1(config-if)#do sh inter trunk
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/1    on           802.1q         trunking      1
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/1    1,10,20,30,40
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans allowed and active in management domain
Gig1/0/1    1,10,20,30,40
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/1    1,10,20,30,40
Gig1/0/2    1,10,20,30,40
Gig1/0/14   40
Gig1/0/15   40

Core1(config-if)#


Core2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core2(config)#inte
Core2(config)#interface g
Core2(config)#interface gigabitEthernet 1/0/2
Core2(config-if)#sw
Core2(config-if)#switchport tr
Core2(config-if)#switchport trunk enc
Core2(config-if)#switchport trunk encapsulation do
Core2(config-if)#switchport trunk encapsulation dot1q 
Core2(config-if)#switchport mode
Core2(config-if)#switchport mode tr
Core2(config-if)#switchport mode trunk 
Core2(config-if)#sw
Core2(config-if)#switchport non
Core2(config-if)#switchport nonegotiate 
Core2(config-if)#switchport trunk all
Core2(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core2(config-if)#^Z
Core2#
%SYS-5-CONFIG_I: Configured from console by console

Core2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core2(config)#inter
Core2(config)#interface g
Core2(config)#interface gigabitEthernet 1/0/14
Core2(config-if)#sw
Core2(config-if)#switchport tr
Core2(config-if)#switchport trunk enc
Core2(config-if)#switchport trunk encapsulation do
Core2(config-if)#switchport trunk encapsulation dot1q 
Core2(config-if)#sw
Core2(config-if)#switchport mode
Core2(config-if)#switchport mode tr
Core2(config-if)#switchport mode trunk 
Core2(config-if)#sw
Core2(config-if)#switchport non
Core2(config-if)#switchport nonegotiate 
Core2(config-if)#sw
Core2(config-if)#switchport tr
Core2(config-if)#switchport trunk all
Core2(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core2(config-if)#exit
Core2(config)#interface gigabitEthernet 1/0/15
Core2(config-if)#switchport trunk encapsulation dot1q 
Core2(config-if)#switchport mode trunk 
Core2(config-if)#switchport nonegotiate 
Core2(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Core2(config-if)#^Z
Core2#
%SYS-5-CONFIG_I: Configured from console by console

Core2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Core2(config)#vlan 10
Core2(config-vlan)#name VLAN10
Core2(config-vlan)#exit
Core2(config)#vlan 20
Core2(config-vlan)#name VLAN20
Core2(config-vlan)#exit
Core2(config)#vlan 30
Core2(config-vlan)#name VLAN30
Core2(config-vlan)#exit
Core2(config)#vlan 40
Core2(config-vlan)#name VLAN40
Core2(config-vlan)#exit
Core2(config)#inter
Core2(config)#interface vlan 10
Core2(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Core2(config-if)#exit
Core2(config)#inter
Core2(config)#interface vlan 20
Core2(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Core2(config-if)#exit
Core2(config)#interface vlan 30
Core2(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

Core2(config-if)#exit
Core2(config)#interface vlan 40
Core2(config-if)#
%LINK-5-CHANGED: Interface Vlan40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up

Core2(config-if)#exit
Core2(config)#^Z
Core2#
%SYS-5-CONFIG_I: Configured from console by console

Core2#sh interfaces tr
Core2#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig1/0/2    on           802.1q         trunking      1
Gig1/0/14   on           802.1q         trunking      1
Gig1/0/15   on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans allowed and active in management domain
Gig1/0/2    1,10,20,30,40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/0/2    40
Gig1/0/14   1,10,20,30,40
Gig1/0/15   1,10,20,30,40

Core2#


Access(config-if)#exit
Access(config)#vlan 20
Access(config-vlan)#name VLAN20
Access(config-vlan)#exit
Access(config)#inter
Access(config)#interface vlan 20
Access(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Access(config-if)#exit
Access(config)#vlan 30
Core2(config-vlan)#name VLAN30
Access(config-vlan)#exit
Access(config)#inter
Access(config)#interface vlan 30
Access(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

Access(config-if)#exit
Access(config)#vlan 40
Core2(config-vlan)#name VLAN40
Access(config-vlan)#exit
Access(config)#inter
Access(config)#interface vlan 40
Access(config-if)#
%LINK-5-CHANGED: Interface Vlan40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up

Access#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Access(config)#inter
Access(config)#interface fa
Access(config)#interface fastEthernet 0/1
Access(config-if)#switchport mode trunk 
Access(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Access(config-if)#switchport nonegotiate 
Access(config-if)#exit
Access(config)#interface fastEthernet 0/2
Access(config-if)#switchport mode trunk 
Access(config-if)#switchport nonegotiate 
Access(config-if)#switchport trunk allowed vlan 1,10,20,30,40
Access(config-if)#^Z
Access#
%SYS-5-CONFIG_I: Configured from console by console

Access#sh inter
Access#sh interfaces tr
Access#sh interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1,10,20,30,40
Fa0/2       1,10,20,30,40

Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,30,40
Fa0/2       1,10,20,30,40

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       none
Fa0/2       40

Access#
%LINK-5-CHANGED: Interface FastEthernet0/24, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up

Access#
Access#en
Access#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Access(config)#inter
Access(config)#interface fa
Access(config)#interface fastEthernet 0/24
Access(config-if)#switchport mode access 
Access(config-if)#switchport access vlan 40
Access(config-if)#
Access(config-if)#^Z
Access#
%SYS-5-CONFIG_I: Configured from console by console

Access#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Access(config)#inte
Access(config)#interface fa
Access(config)#interface fastEthernet 0/10
Access(config-if)#switchport mode
Access(config-if)#switchport mode access 
Access(config-if)#sw
Access(config-if)#switchport acc
Access(config-if)#switchport access vlan 10
Access(config-if)#exit
Access(config)#interface fastEthernet 0/15
Access(config-if)#switchport mode access 
Access(config-if)#switchport access vlan 30
Access(config-if)#exit
Access(config)#interface fastEthernet 0/20
Access(config-if)#switchport mode access 
Access(config-if)#switchport access vlan 20
Access(config-if)#^Z
Access#

Access#sh interfaces fastEthernet 0/24 switchport 
Name: Fa0/24
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 40 (VLAN40)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

Access#sh interfaces fastEthernet 0/3 switchport 
Name: Fa0/3
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (VLAN10)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

Access(config-if)#do sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/21
                                                Fa0/22, Fa0/23, Gig0/1, Gig0/2
10   VLAN10                           active    Fa0/10
20   VLAN20                           active    Fa0/20
30   VLAN30                           active    Fa0/15
40   VLAN40                           active    Fa0/24
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
40   enet  100040     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Access(config-if)#

Dispositivos finales. Configurar IPs, vlan 10, vlan 20, vlan 30, vlan 40:

VLAN 10:
C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::201:C7FF:FE4D:C4D5
   IP Address......................: 10.16.0.10
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 10.16.0.1

C:\>

VLAN 20:
C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::201:63FF:FE51:CDBB
   IP Address......................: 10.16.2.10
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 10.16.2.1

C:\>

VLAN 30:
C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::2D0:D3FF:FE52:1C79
   IP Address......................: 10.16.5.10
   Subnet Mask.....................: 255.255.254.0
   Default Gateway.................: 10.16.4.1

C:\>

VLAN 40:
C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::201:63FF:FE50:4ABB
   IP Address......................: 10.16.7.10
   Subnet Mask.....................: 255.255.254.0
   Default Gateway.................: 10.16.6.1

C:\>

Comprobar conectividad:





Conexión a Internet

Internet(config)#no ip dhcp pool ISP
Internet(config)#ip dhc
Internet(config)#ip dhcp poo
Internet(config)#ip dhcp pool ISP
Internet(dhcp-config)#network 193.37.255.0 255.255.255.252
Internet(dhcp-config)#de
Internet(dhcp-config)#default-router 193.37.255.1
Internet(dhcp-config)#dns
Internet(dhcp-config)#dns-server 1.1.1.1
Internet(dhcp-config)#^Z
Internet#
%SYS-5-CONFIG_I: Configured from console by console

Internet#
Internet#wri
Building configuration...
[OK]
Internet#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Internet(config)#inter
Internet(config)#interface g
Internet(config)#interface gigabitEthernet 0/0
Internet(config-if)#ip add
Internet(config-if)#ip address 193.37.255.1 255.255.255.252
Internet(config-if)#no shut

Internet(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Internet(config-if)#%DHCPD-4-PING: DHCP address:  server pinged 193.37.255.1.

Internet(config-if)#sh ip dhcp
Internet(config-if)#do sh ip inter
Internet(config-if)#do sh ip inter
Internet(config-if)#do sh ip inter b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     193.37.255.1    YES manual up                    up 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     unassigned      YES unset  administratively down down 
Serial0/0/0            unassigned      YES manual administratively down down 
Serial0/0/1            unassigned      YES unset  administratively down down 
Vlan1                  unassigned      YES unset  administratively down down
Internet(config-if)#

R1-NV#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up

%DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0/2 assigned DHCP address 193.37.255.2, mask 255.255.255.252, hostname R1-NV


R1-NV#
R1-NV#sh ip inter
R1-NV#sh ip interface b
Interface              IP-Address      OK? Method Status                Protocol 
GigabitEthernet0/0     unassigned      YES manual administratively down down 
GigabitEthernet0/1     unassigned      YES unset  administratively down down 
GigabitEthernet0/2     193.37.255.2    YES DHCP   up                    up 
FastEthernet0/0/0      unassigned      YES unset  up                    up 
FastEthernet0/0/1      unassigned      YES unset  up                    down 
FastEthernet0/0/2      unassigned      YES unset  up                    down 
FastEthernet0/0/3      unassigned      YES unset  up                    down 
Serial0/1/0            unassigned      YES manual down                  down 
Serial0/1/1            unassigned      YES unset  down                  down 
Vlan1                  unassigned      YES unset  administratively down down 
Vlan10                 10.16.0.1       YES manual up                    up 
Vlan20                 10.16.2.1       YES manual up                    up 
Vlan30                 10.16.4.1       YES manual up                    up 
Vlan40                 10.16.6.1       YES manual up                    up
R1-NV#wri
Building configuration...
[OK]
R1-NV#


Cisco es genial!.